1. Familiarization with the Computer System:
   - To explain the part of the computer system such as system unit, input devices, output devices connected to the computer.
   - To explore the outside view of the system unit that includes the panels on front and ports at the rear.
   - To explore the inside view of the system unit that includes the motherboard, processor, expansion slots, various add on cards, storage devices, power supply, fans.
   - To understand the booting process that includes switching on the system, execution of POST routine, then bootstrap loader, and loading the operating system, and getting it ready for use.
   - To introduce the graphical user interface (desktop) of Windows operating system
     - to explain the various elements of the desktop such as taskbar, icons (My Computer, Recycle Bin, etc.), short cuts, notification area.
     - to configure the desktop that include selecting the wall paper, selecting the screen saver with or without password protection, selecting the screen resolution and color quality.

2. Navigating with Window Explorer:
   - To navigate with the drives
   - To create new folders
   - To move folders from one drive to another drive
   - To move files from one folder to another folder
   - To search files and folders
   - To share files and folders
   - To view and/or change the attributes of the files and folders

3. Working with Control Panel:
- To work with date and time
- To create new user accounts
- To install new hardware and configuring existing hardware
- To install new software or remove existing installed software
- To configure network connections
- To manage security profile

4. Miscellaneous Features:
- To work at the command prompt
- To open an application, folder, document or internet resource from the Run command
- To initialize storage media (formatting)
- To understand the menace of viruses
- To understand the working of virus guards and antivirus software

5. Exploring the Internet:
- To understand the working of the internet that include the use of protocols, domains, IP addresses, URLs, web browsers, web servers, mail servers, etc.
- To create email account, sending mails, receiving mails, sending files a attachments, etc.
- To login to a remote computer
- To search information using search engines

6. Microsoft Word:
- To familiarize with parts of Word window
- To create and save a document
- To set page settings, create headers and footers
- To edit a document and resave it
- To use copy, cut and paste features
- To use various formatting features such as bold face, italicize, underline, subscript, superscript, line spacing, etc.
- To use spelling and grammar checking feature
To preview print a document

7. Microsoft Word continued:
   - To create a table with specified rows and columns
   - To enter data in a table
   - To select a table, a row, a column or a cell
   - To inset new row and/or a column
   - To delete a row and/or a column
   - To split and merge a row, column or a cell
   - To understand the mail merge and to use mail merge feature of MS Word

8. Microsoft Excel:
   - To familiarize with parts of Excel window
   - To create and save a workbook with single and/or multiple worksheets
   - To edit and format text as well numbers
   - To apply operations on range of cells using built in formulae
   - To preview and print a worksheet

9. Microsoft Excel continued:
   - To insert new row and/or column in a worksheet
   - To delete a row and/or column in a worksheet
   - To create a variety of charts
   - To import and export data to or from worksheet

10. Microsoft PowerPoint:
    - To familiarize with parts of PowerPoint window
    - To create and save a new presentation
    - To apply design templates to a presentation
    - To insert, edit and delete a slide
    - To use different views of slides
    - To use slide show from beginning or from the current slide
- To preview and print a presentation

11. Microsoft PowerPoint continued:
- To check spellings in a presentation
- To add clip art and pictures in a slide
- To add chart, diagram and table in a slide
- To set animation for a selected slide and/or for entire presentation
- To create slide master and title master
- To create a custom show

12. Write a program to find the nature of the roots as well as value of the roots. However, in case of imaginary roots, find the real part and imaginary part Separately.

13. Write a program, which takes two integer operands and one operator form user, performs the operation and then prints the result. (Consider the operators +, -, *, /, % and use switch statement). For e.g., the input should be in the form: 5 + 3 the output should comes Result = 8.

14. Fibonacci sequence is defined as follows: the first and second terms in the sequence are 0 and 1. Subsequent terms are found by adding the preceding two terms in the sequence. Write a program to generate the first n terms of the sequence. For example, for n= 8, the output should be 0 1 1 2 3 5 8 13.

15. Write a program to print all the prime numbers between m and n, where the value of m and n is supplied by the user.

16. The number such as 1991, is a palindrome because it is same number when read forward or backward. Write a program to check whether the given number is palindrome or not.

17. A positive integer number IJK is said to be Well ordered if I<J<K. For example, number 138 is called well ordered because the digits in the number (1, 3, 8) increase from left to right, i.e., 1 < 3 < 8. Number 365 is not well ordered because 6 is larger than 5. Write a program that will find and display all possible three digit well ordered numbers. The program should also display the total number of three digit well ordered numbers found.

18. Write a function to computer the highest common factor of integer numbers m and n. Use this function to find the highest common factor of integer numbers a and b.

19. Given the marks (out of 100) obtained by each student in a test of a class with n students. Write a program to obtain the following information:

(a) minimum and maximum marks score.

(b) average score of the class, and.
(c) number of students whose score is greater than class's average score.

20. Write a program to multiply matrix $A_{m \times n}$ by $B_{p \times q}$, given that $n = p$.

21. Write a program to sort a list of $n$ integer numbers in descending order using bubble sort method.

22. Create a class named Student with the appropriate data members and member functions to generate output comprising student's admission no., name, marks in five subjects and the %age of marks obtained. Write a program to use the Student class.

23. Create a class named Complex Number with the appropriate data members and constructors. Include member functions (defined inside the class) to perform the following operations:

(a) Inputting a complex number

(b) Outputting a complex number

(c) Arithmetic operations on two complex numbers

Write an appropriate program to demonstrate use of the Complex Number class.

24. Create a class named Height with feet and inches as its data members. Also include appropriate constructors (and destructor, if required). Include member functions (defined outside the class) to perform the following operations:

(a) Inputting a height of a person

(b) Displaying a height of a person

(c) To get height in inches

(d) To compare two heights

Write an appropriate program to demonstrate use of the Height class.
<table>
<thead>
<tr>
<th>Sr. No.</th>
<th>Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Familiarization with the computer system</td>
</tr>
<tr>
<td>2</td>
<td>Navigating with Window Explorer.</td>
</tr>
<tr>
<td>3</td>
<td>Working with Control Panel.</td>
</tr>
<tr>
<td>4</td>
<td>Miscellaneous Features.</td>
</tr>
<tr>
<td>5</td>
<td>Exploring the Internet.</td>
</tr>
<tr>
<td>6</td>
<td>Working with MS-Word</td>
</tr>
<tr>
<td>7</td>
<td>Working with MS-Excel</td>
</tr>
<tr>
<td>8</td>
<td>Working with MS-Powerpoint</td>
</tr>
<tr>
<td>9</td>
<td>Write a program to find the nature of the roots as well as value of the roots. However, in case of imaginary roots, find the real part and imaginary part Separately.</td>
</tr>
<tr>
<td>10</td>
<td>Write a program, which takes two integer operands and one operator form user, performs the operation and then prints the result.</td>
</tr>
<tr>
<td>11</td>
<td>Fibonacci sequence is defined as follows: the first and second terms in the sequence are 0 and 1. Subsequent terms are found by adding the preceding two terms in the sequence. Write a program to generate the first n terms of the sequence. For example, for n= 8, the output should be 0 1 1 2 3 5 8 13.</td>
</tr>
<tr>
<td>12</td>
<td>Write a program to print all the prime numbers between m and n, where the value of m and n is supplied by the user.</td>
</tr>
<tr>
<td>13</td>
<td>The number such as 1991, is a palindrome because it is same number when read forward or backward. Write a program to check whether the given number is palindrome or</td>
</tr>
</tbody>
</table>
A positive integer number $IJK$ is said to be well ordered if $I<J<K$. For example, number 138 is called well ordered because the digits in the number $(1, 3, 8)$ increase from left to right, i.e., $1 < 3 < 8$. Number 365 is not well ordered because 6 is larger than 5. Write a program that will find and display all possible three digit well ordered numbers. The program should also display the total number of three digit well ordered numbers found.

Write a function to compute the highest common factor of integer numbers $m$ and $n$. Use this function to find the highest common factor of integer numbers $a$ and $b$.

Given the marks (out of 100) obtained by each student in a test of a class with $n$ students. Write a program to obtain the following information:

(a) minimum and maximum marks score.
(b) average score of the class, and.
(c) number of students whose score is greater than class's average score.

Write a program to multiply matrix $A_{m \times n}$ by $B_{p \times q}$, given that $n = p$.

Write a program to sort a list of $n$ integer numbers in descending order using bubble sort method.

Create a class named Student with the appropriate data members and member functions to generate output comprising student's admission no., name, marks in five subjects and the %age of marks obtained. Write a program to use the Student class.

Create a class named Complex Number with the appropriate data members and constructors. Include member functions (defined inside the class) to perform the following operations:

(a) Inputting a complex number
(b) Outputting a complex number
(c) Arithmetic operations on two complex numbers

Write an appropriate program to demonstrate use of the Complex Number class.
Create a class named Height with feet and inches as its data members. Also include appropriate constructors (and destructor, if required). Include member functions (defined outside the class) to perform the following operations:
(a) Inputting a height of a person
(b) Displaying a height of a person
(c) To get height in inches
(d) To compare two heights
Write an appropriate program to demonstrate use of the Height class.

*Write a program for display a message.
*Write a program for addition, subtraction, multiplication and Division of two integer numbers.
*Write a program to find greatest of three numbers.
*Write a program to add two numbers using function.

1. * Learning Beyond Syllabus Write a program for display a message.
2. * Learning Beyond Syllabus Write a program for addition, subtraction, multiplication and Division of two integer numbers.
3. * Learning Beyond Syllabus Write a program to find greatest of three numbers.
4. * Learning Beyond Syllabus Write a program to add two numbers using function.
AIM: Familiarization with the Computer System.

Objective: Providing basic information so that students become familiar to various peripheral devices.

S/W Requirement: Operating System

H/W Requirement: Keyboard, Mouse, CPU, Motherboard, RAM, Hard disk, printers.

Theory:

RAM: Random Access Memory (RAM): allows data and instructions to be accessed randomly from any memory location (address). Primary storage.

Volatile - lost when power is turned off

Motherboard: Attachments to the motherboard include:

- Main Memory: types of main memory include:
  - RAM - temporary (includes virtual memory storage). Include RAM cache
  - ROM - permanent

When add main memory, make sure add-on chips are compatible

- Real time clock (current date and time)
- Microprocessor or CPU (central processing unit)
- Control Unit: traffic cop portion of the CPU
- ALU: arithmetic logic unit processes all math and logical operations performed by the computer

CPU: Control Unit: works with the operating system to move data between auxiliary storage and main memory; and between main memory and the ALU

- Arithmetic/Logic Unit (ALU): processes data arithmetically (addition, subtraction, multiplication, division) or logically (greater than, less than, equal to)
- Main Memory: contains both program instructions and the data that is required.
- A single machine can have multiple CPUs to share processing tasks (co-processors, multiprocessing), but each CPU can execute only a single task.

Keyboard: Windows PCs use tow basic types of keyboards that are classified by the number of keys they have:
– 101-key Enhanced keyboard
– 104-key Windows keyboard

- The windows keyboard has some extra keys that address windows specific functions such as opening the start menu or opening the shortcut menu.
- Many new style keyboards also include keys or buttons for connecting to the internet, sending and receiving emails, and adjusting the volume of the sound system – separate software needed to manage them.

**Mouse:** Parts of a typical mouse:

Right Button

Left Button

Scroll Wheel

Mouse terms:

- Right Click - clicking the right mouse button once
- Left Click - clicking the left mouse button once
- Double-click - clicking a button twice in rapid succession
- Dragging - holding a button down over an object while moving the mouse
- Dropping - letting the mouse button up after a drag

**Printer:**

A *computer printer*, or more commonly a *printer*, is a computer peripheral which produces a hard copy (permanent human-readable text and/or graphics) of documents stored in electronic form, usually on physical print media such as paper or transparencies. Many printers are primarily used as local peripherals, and are attached by a printer cable to a computer which serves as a document source. Some printers, commonly known as *network printers*, have built-in network interfaces (typically wireless or Ethernet), and can serve as a hardcopy device for any user on the network. Individual printers are often designed to support both local and network connected users at the same time.

Different Types are:

Dot Matrix

Ink jet printer

Laser Printer
AIM: Navigating with Window Explorer.

Objective: As the windows operating system is an important component of computer without which processing could not be done. So they are exposed to this environment.

S/W Requirements: Windows XP.

H/W Requirements: Keyboard, Mouse, Monitor.

Theory:

Windows

The Desktop

The word desktop has been derived from real life desk top were a manager puts all the things required by her. For instance, on a desktop, there may be pen stand, notepad, calculator, etc. Lying, which are required by the manager. The desktop of a Windows also serves the same purpose.
WINDOWS DESKTOP

In Windows Operating System, the screen upon which icons, Windows, etc. are displayed is known as desktop. The Windows Operating System desktop may contain a background, one or more active or inactive windows, a taskbar and icons. A background can be any thing from a single-color screen to an elaborate artistic image. All windows and icons are superimposed on the background, whatever it may be.

The Icons

Icons are the pretty pictures representing Windows elements like files, folders, shortcuts, etc. Icons play a very important role in graphical user interface.

Commonly used icons are:

1. **Application icons**: These are the graphic rendering of the software package’s logo. If you double click over this icon, the related application gets invoked.

   ![Microsoft Excel](image1)
   ![Microsoft Access](image2)
   ![Microsoft Word](image3)

2. **Shortcuts icons**: These are little graphics pointing to a particular application, document or folder, etc. By double clicking over them the concerned application/document/folder etc. becomes active.

   ![Windows Media Player](image4)
   ![Shortcut to My Computer](image5)
   ![Shortcut to Turbo C++](image6)

3. **Document icons**: The active document window, which is a window within an application window, can be minimized to a document icon. Point and double click on the document icon to restore the document window.

   ![Shortcut to DESIGN.doc](image7)
   ![Shortcut to ASP Lecture](image8)
   ![Shortcut to EULA.txt](image9)
4. **Disk-drive icons**: Disk-drive icons graphically represent five disk drive options: floppy disk, hard-disk, network, Ram, and CD-ROM. The floppy disk, hard-disk and CD-ROM icons resemble the faceplates of the disk drives. Typically, PCs have only one or two floppy drives, assigned to A and B.

**DISK DRIVE ICONS**

The Taskbar

This is bar that is usually found at the bottom of your screen. The start button about which we have discussed just now is located on the task bar only.

Apart from the start button, the taskbar hosts the clock, some toolbar and the buttons corresponding to all open windows.

Buttons on the taskbar show you which windows are open, even if some windows are minimized or hidden beneath another window. You can easily switch to a different window by clicking its taskbar button. That is, if you are currently working in Microsoft Excel’s window and now you want to switch to Microsoft PowerPoint, which is also active in another window, then, all you need to do is: “click the button representing Microsoft PowerPoint on the taskbar”.

**The Start Button**

Using start button, we can accomplish almost any task. We can start programs, open documents, customize system, get Help, search for items on our computer, and more. Some commands on the start menu have right-facing arrow which means additional choices are available on a secondary menu. If we place our pointer over an item with an arrow, another menu appears.
To use the Start Menu

1. Click the start button. The start menu appears.
2. Click the option you want to open. Point to option with right-facing arrows to open secondary menu.

Starting and Closing Programs

Most of the programs on the computer are available one convenient location- the Programs section of the Start menu. Depending on how your computer is set up, what you see on the Start menu varies.

To start a program

( MS Paint located on Accessories Group)

1. Click the start button, and then point to programs. The programs sub-menu appears.
2. Point to the group such as Accessories here that contains the program you want to start and then click the program name i.e., on MSPaint in our case.

To quit an open program

1. Just click the close button in the upper-right corner of the program window
2. Alternatively, you can also click upon Exit option available on the File menu of the application or you can also press the shortcut key Alt+F4.
**Window control buttons**

You can work with open windows in Windows 98 by clicking one of the window control buttons located on the far right of the title bar.

- **MINIMIZE:** It is used to minimize a window. A minimized window is still open, and a window button appears on the taskbar.

- **RESTORE:** Return a window to its previous size i.e., the original size in which it was opened.

- **CLOSE:** It is used to close the window.

**Control Panel**

This is used to change the settings of your computer. When you click on the Control Panel on Task bar windows showing the contents of it appears.

**Conclusion:** Students are made familiar with the windows operating system, its icons and menus and Control Panel through the working.
AIM: Working with Control Panel.

Control Panel provides a set of special-purpose administrative tools that you can use to configure the Windows, applications, and services environment. Control Panel includes default items that you can use for common tasks (for example, Display and Add Hardware). User-installed applications and services can also insert icons into Control Panel.

There are two view options for Control Panel: Category View and Classic View.

- **Category View** displays Control Panel icons according to the type of task that the user wants to perform.
- **Classic View** displays Control Panel icons in a view that is familiar to users of previous versions of Windows.

To Open the Control Panel in Classic View:

1. Select **Start** | **Control Panel**.
2. The Control Panel should automatically open in Classic View.

To Set the Control Panel to Category View

1. Open the Control Panel.
2. From the top of the screen select Tools | Folder Options.
3. Under the **General Tab**, Select **Show common tasks in folders** from the Tasks sections of the dialog box.

![Folder Options](image)

4. The Control Panel should now be set to Category View.

![Control Panel in Category View](image)

**To Switch Back to Classic View:**

1. Select the **Switch to Classic View** button in the pane on the left-hand side of the screen.
AIM: Miscellaneous Features.

Windows XP also adds a little flavor to the Services screen in Computer manager. If you are coming from a Windows 9x environment, Services are applications that can run on a system without a user being actively logged on.

As you can see in this screenshot, when you select a service, the left side of the screen gives you ability to start or restart the service, as well as showing you a description of the service.

New Groups

There are some new groups that can be found in XP as well. The picture below is a little small, so if you want to see a full screen view of this screenshot, click on the image and a larger one will emerge.

Three Groups listed here are of interest and they are the “Network Configuration Operators,” “Remote Desktop Users,” and the “HelpServicesGroup.” Network Configuration Operators are used to designate who can manage network configuration with administrative-type access. These users do not have administrative access to your system, but they do have it within the scope of “Network and Dial up Connections.” Remote Desktop Users have the ability to log on remotely. The Help Services Group seems to be a little…strange. The only member is a user called “Support_#####” which has a description of “This is a vendor's account for the Help and Support.” This user account has the options of “Password Never expires” and “User cannot Change Password” enabled. Could this be a back door to your system for Microsoft….maybe…?

Speaking of User Accounts:
User Accounts

Just about every review that I’ve seen on XP has shown the new opening screen for User Accounts. They also show you that you can change the picture associated with a user account. What I hadn’t seen poking around on the internet was this option:

Now this is a pretty good idea! I was pretty impressed with this improvement. Of course there will be persons saying “This is a security risk.” OK. That may be true, but have you ever dealt with a user that could not remember his or her password? This option creates a boot floppy that holds authentication for a particular user account in case they forget what their password was. When the user attempts to Log on to the system, with an incorrect password this screen appears:

Do you see the last option? Click here to use your password reset disk. If you select this option, Windows prompts you for the disk and forces you to reset your password. The disk can be used over and over again, but your password is now different. The password is updated on the floppy when you change it. If you decide to set a password with a user account, XP gives you to the option to secure all of your files:

If you tell XP to make your files Private, it will… Maybe. I could still log on as Steve and see all of the songs that belonged to me. Maybe I forgot something, or perhaps this is something that will be fixed in a later release. What about Network Connectivity?
AIM: Exploring the Internet.

Internet, another choice on the Start menu, opens Internet Explorer; the web browser that comes bundled with Windows XP.

To launch Internet Explorer from the Start menu:

1. Click Start.
2. Choose Internet.
3. Click to open Internet Explorer.
4. To close a program, click the located at the top-right of the window.

Note: You must be connected to the Internet for Internet Explorer to open a webpage.
AIM: Working with MS Word.

Objective: To understand the Word in depth like creating, editing, formatting and printing the documents and to understand its good tools like Mail merge

S/W Requirements: MS-Office (MS-Word)

H/W Requirements: Keyboard, Mouse, Monitor.

Introduction to MS-Word

Microsoft Word is Microsoft's flagship word processing software. It was first released in 1983 under the name Multi-Tool Word for xenix systems. It is a component of the Microsoft system; however, it is also sold as a standalone product and included in Microsoft works suite. Beginning with the 2003 version, the branding was revised to emphasize Word's identity as a component within the Office suite; Microsoft began calling it Microsoft Office Word instead of merely Microsoft Word. The latest release is Word 2008 for Mac OS X.

Starting Microsoft Word

- **Two Ways**
  1. Double click on the Microsoft Word icon on the desktop.
  2. Click on Start --> Programs --> Microsoft Word
Special Features of MS word

- Creating a new document
- Toolbars
- Formatting
- Editing
- Shortcuts
- Other helpful functions

CREATING A NEW DOCUMENT

Many of the steps you are about to read are for both PC and Mac computers. Some of the steps have very similar descriptions. For your benefit, this tutorial has combined the information but will offer different screen shots for each system when necessary.

OPENING MICROSOFT WORD ON A PC

To launch Microsoft Word, go to Start > Programs > Microsoft Office > Microsoft Office Word. A blank Word document will open.

Navigate to Microsoft Word on a PC TOOLBARS

Microsoft Word uses toolbars to allow you to modify your document. When you first open Word, usually the three toolbars discussed below will open. However, each computer may set up these toolbars differently, so they will usually look different than the toolbars below. If you do not see these toolbars, or to open up other toolbars, go to View Toolbars and place a checkmark by the toolbar you wish to open. If you do not see an icon you expect on a toolbar, click on the arrow at the end of the toolbar to reveal hidden icons. Word will also allow you to customize your toolbars by going to View > Toolbars > Customize.
THREE COMMONLY USED TOOLBARS

The Menu bar: This toolbar is constructed of word commands and not icons (pictures). The Menu bar contains all the options available to you in Microsoft Word. Using this toolbar to format and change your document will often allow you greater control than using the icons on the other toolbars. However, the other toolbars may be more convenient.

Menu bar.

The Standard toolbar: This toolbar contains icons from common commands such as Save, Print, Tables, and Spell Check. These icons are convenient but will not bring up the dialogue boxes that allow you to change the settings of these actions. You should use whichever method works the best for you.

Standard toolbar.

The Formatting toolbar: This toolbar contains icons for common formatting actions, such as Font Style, Font Size, Bold, Italic, Underline, Alignment, Numbered List, Bulleted List, Indentation, Spacing, and Font Color. These icons are convenient but will not bring up dialogue boxes that allow you to change the settings of these actions. You should use whichever method works the best for you.

Formatting toolbar.

FORMATTING

FORMATTING THE DOCUMENT

The default page margin for Microsoft Word documents is 1.25 inches, not the 1 inch normally required by instructors. Therefore, it is necessary to change the page margins of your document. To do this on a Mac, go to Format > Document. To change the page margins on a PC, go to File > Page Setup >
Margins. A menu will appear where you can type the desired margin size.

![Margins Menu](image)

Changing Margins in the Document Format Menu

![Document Format Menu](image)

From the same menu (Figure 1), select **Layout** to customize the layout of your document. Click on **Page Setup**, and then select the orientation of your document. Click **Portrait** if you want your document to be 8.5 x 11 inches (most common). Click **Landscape** if you want your document to be 11 x 8.5 inches. Landscape simply flips the page 90 degrees.
**FORMATTING PARAGRAPHS**

To format your paragraph, first highlight the paragraph you wish to format. To highlight more than one paragraph, click at the beginning of the paragraph and drag the mouse over the text. To apply changes to the entire document, go to **Edit > Select All**. To specify **Alignment**, **Line Spacing**, **Indentation**, and **Page Break** click **Format > Paragraph**. This will open up the Paragraph menu (Figure 2). The **Alignment** option allows you to choose how you want your paragraph to look (i.e. justified, right, center, or left). The **Line Spacing** option allows you to set the desired spacing, such as single or double. The **Indentation** option allows you to tab/push the line(s) in your paragraph either left or right. The **Page Break** option is found in **Paragraph** menu, but you must first select the **Line and Page Breaks** tab. **Page break** allows you to split a paragraph or a page up into sections. You can also bring up this menu by right clicking (or by hitting CONTROL + click on a one button mouse) within the document and selecting **Paragraph**.

![Changing the Paragraph attributes with the Paragraph menu.](image)

**FORMATTING TEXT**

Before you type, you should select your font style, size, color and attributes (such as bold, italic and underline) by using the **Formatting** toolbar or by going to **Format > Font**. This will open the Font menu (Figure 3). However, if you wish to change text that has already been typed, click and drag over the text to be changed to highlight it (or go to **Edit > Select All** to select the entire document) and change it as before.
Changing the font attributes in the Font menu.

NUMBERED AND BULLETED LISTS

To create a simple numbered or bulleted list, click on the Number or Bullet button on the Formatting toolbar. To have more control over the format of your list, go to Format > Bullets and Numbering. This will open up the Bullets and Numbering Menu. Select your desired list format and click OK. Type the first item in the list and press RETURN to move to the next number or bullet. Press RETURN twice to exit the list.

EDITING

Cut and Paste

In Microsoft Word, you can cut (delete) text from one area of a document and save that text so it can be pasted elsewhere in the document. When you cut text, it is stored on the Clipboard. You can also copy text. When you copy text, it is also stored on the Clipboard. Information stored on the Clipboard stays there until new information is either cut or copied. Each time you execute
Cut or Copy, you replace the old information on the Clipboard with whatever you just cut or copied. You can paste Clipboard information as often as you like.

**Cut - Using the Menu**

1. Type the following:
   
   I want to move. I am content where I am.
2. Highlight "I want to move."
3. Choose Edit > Cut from the menu.
4. Your text should now read:
   "I am content where I am."

**Paste - Using the Menu**

1. Place the cursor after the period in the sentence "I am content where I am."
2. Press the spacebar to leave a space.
3. Choose Edit > Paste from the menu.
4. Your text should now read
   "I am content where I am. I want to move."

**Copy and Paste**

In Microsoft Word, you can copy text from one area of the document and place that text elsewhere in the document. As with cut data, copied data is stored on the Clipboard.

**Copy - Using the Menu**

1. Type the following:
   
   You will want to copy me. One of me is all you need.
2. Highlight "You will want to copy me."
3. Choose Edit > Copy from the menu.

**Find and Replace**

These functions help you locate and replace a certain word or phrase in your document. To use these options, click on the Edit tab and click on “Find or Replace”. The difference between these is that the Find command will do just that; it will locate the word(s) you are looking for, but that’s all. The Replace command will ask for the word or phrase you wish to change, along with the word or phrase you would
like to use instead. When you use either of these commands, Word will locate every instance of the word or phrase in question, not just the first one.

**Font Size**

In Microsoft Word, you can change the size of your font (text). The following exercise illustrates changing the font size.

**Change Font Size - Using the Menu**

1. Type the following:
   
   *I am the smallest. I am a little bigger. I am the biggest.*
2. Highlight "I am the smallest."
3. Choose Format > Font from the menu.
4. Choose the Font tab.
5. Type 8 in the Size field, or click 8 in the box below the Size field.
6. Click OK.
7. Highlight "I am a little bigger."
8. Choose Format > Font from the menu.
9. Choose the Font tab.
10. Type 14 in the Size field, or click 14 in the box below the Size field.
11. Click OK.
12. Highlight "I am the biggest."
13. Choose Format > Font from the menu.
14. Choose the Font tab.
15. Type 24 in the Size field, or click 24 in the box below the Size field.
16. Click OK.
17. Your text should now look similar to the following:

   "I am the smallest. I am a little bigger. I am the biggest."

**Undo and Redo**

In order to undo an action, go to Edit > Undo. To redo an action, go to Edit > Redo. It is important to note that not all actions are undoable, thus it is important to save before you make any major changes in your document so you can revert back to your saved document.
Common Shortcuts

These are some common shortcuts that you can use on your keyboard in almost any Microsoft Office program:

Copy: CTRL + C
Align Left: CTRL + L
Bold: CTRL + B
Spell Check: F7
Select All: CTRL + A
Cut: CTRL + X
Align Right: CTRL + R
Italic: CTRL + I
Thesaurus: SHIFT + F7
Undo: CTRL + Z
Paste: CTRL + V
Align Center: CTRL + E
Underline: CTRL + U
Find: CTRL + F
Save: CTRL + S
Help: SHIFT + F1
Redo: CTRL + Y

Other helpful functions

Insert option

To insert a table:

• Click on the Table button in the toolbar, or click on the Table tab at the top of the screen, then click “Insert”, and “Table”.
• You will have to specify the number of columns and rows, and then click OK.

To add rows or columns in a table:

• Click on a cell where you would like to insert a row or column.

• Click on the Borders and Tables button.

• In the toolbar that comes up, click on the word Table
• Click on one of the Insert Rows/Insert Columns choices that appear.

**To delete rows or columns:**
• Click on a cell in the row or column you would like to delete.
• Click on the Borders and Tables button.
• In the toolbar that comes up, click on the word Table.
• Click on either Delete Rows or Delete Columns.

**Inserting Symbols:**

To insert a symbol that isn’t on the keyboard (for example, ÷, ©, 8, ., δ, etc.), click on the Insert tab, and then click on “Symbol”. You can choose which symbol you would like to use, then click on the Insert button when that symbol is highlighted. Click on the Close button to return to your document.

**Spell Check**

Word checks your spelling and grammar as you type. Spelling errors display with a red wavy line under the word. Grammar errors display with a green wavy line under the error. If you want to spell check your entire document, press F7 and click the spelling icon , or choose Tools > Spelling and Grammar from the menu. If you want to spell check part of your document, highlight the area you want to spell check. Then press F7 and click the spelling icon , or choose Tools > Spelling and Grammar from the menu.

![Spell Check Dialogue Box](image)
**Headers and Footers**

Headers and Footers can be used to give a uniform look to the pages of your document. To create one, go to **View > Header and Footer**. Use the **Header and Footer** toolbar to insert and format words and objects in the header. To move between the header and footer, use the **Switch between Header and Footer** button. Click **Close** to exit the header or footer.

**Mail Merge**

Mail merge enables you to create form letters, mailing labels, envelopes, or catalogs. There are two files needed for a mail merge. The data source contains the data that varies in the merged documents — for example, the name and address of each recipient of a form letter. The data source can be an existing spreadsheet, database, or text file, or a Word table that you create. The main document contains the generic information that you want to repeat in each form letter, mailing label, envelope, or catalog.

In the main document, merge fields («name», «address», «city», «state», «zip») are the placeholders that tell Microsoft Word where to insert data from the data source. Merge fields are identified by the guillemots (« ») around each field. When you execute the merge command, Word automatically generates letters by replacing the merge fields in the main document with the appropriate data from the source document. Each row (or record) in the data source produces an individual form letter, mailing label, envelope, or catalog item. The idea of a mail merge is to save you time and keystrokes; therefore, type as much information in the main document as possible. For instance, if one of your merge fields will be a price (i.e. $14.00), type the dollar sign in the main document so you won’t have to type it for every price in the source document.

**Create a Mail Merge**

**The Main Document**

1. Begin with a new document or you can also use an existing document.

2. Go to Tools Mail Merge... The Mail Merge Helper will open.
3. Select Create. Under Main document and choose the type of document you wish to create.

4. Word will ask if you wish to use the active window as your document or create a new document. If you began with a blank or existing document, choose Active Window. The active document becomes the main document. A new document is created and the Mail Merge tool bar will appear.

**The Data Source**

1. Click **Mail Merge Helper** on the Mail Merge toolbar.

2. Click Get Data. under Data source .

3. Choose one of the following:

- Create Data Source – Use this method if you don’t already have the data stored in another data source.

- Open Data Source – Select a Microsoft Word document, or a worksheet, database, or other list, and then click Open. Click Edit Main Document.

- Use Address Book – Uses addresses from an electronic address book. Select an address book, and then click OK. Click Edit Main Document

**Basic Buttons & Features**

Here are the functions of the basic buttons in the most commonly-used toolbars in most Microsoft programs:
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🔗</td>
<td>Open – Opens or finds a file</td>
</tr>
<tr>
<td>🔗</td>
<td>Open – Opens or finds a file</td>
</tr>
<tr>
<td>🔗</td>
<td>Save – Saves the active document with the current file name, location, and format.</td>
</tr>
<tr>
<td>🔗</td>
<td>E-mail – E-mails the current document</td>
</tr>
<tr>
<td>🔗</td>
<td>Print – Prints the current document</td>
</tr>
<tr>
<td>🔗</td>
<td>Print Preview – Shows what the document will look like when it is printed.</td>
</tr>
<tr>
<td>🔗</td>
<td>Spell &amp; Grammar Check – checks the spelling &amp; grammar of selected text</td>
</tr>
<tr>
<td>🔗</td>
<td>Cut – Removes selected item(s) from the document and places it on the clipboard</td>
</tr>
<tr>
<td>🔗</td>
<td>Paste – Inserts text or objects from the clipboard into a document</td>
</tr>
<tr>
<td>🔗</td>
<td>Undo – Reverses the last command; use pull-down menu to undo several steps</td>
</tr>
<tr>
<td>🔗</td>
<td>Redo – Reverses the action of the undo button; use pull-down menu to redo several steps</td>
</tr>
<tr>
<td>🔗</td>
<td>Hyperlink – Inserts a hyperlink for selected text or objects</td>
</tr>
<tr>
<td>🔗</td>
<td>Tables &amp; Borders – Shows or hides the tables and borders toolbar</td>
</tr>
<tr>
<td>🔗</td>
<td>Insert Table – Inserts a table into a document, or creates a table from selected text</td>
</tr>
<tr>
<td>🔗</td>
<td>Drawing – Shows or hides the drawing toolbar</td>
</tr>
<tr>
<td>🔗</td>
<td>Zoom – Enlarges or reduces the display of the active document</td>
</tr>
<tr>
<td>🔗</td>
<td>Times New Roman – Font – Changes the font of selected text</td>
</tr>
<tr>
<td>🔗</td>
<td>Bold – Displays selected text in <strong>boldface</strong></td>
</tr>
<tr>
<td>🔗</td>
<td>Italic – Displays selected text in <em>italics</em></td>
</tr>
<tr>
<td>🔗</td>
<td>Underline – Underlines selected text</td>
</tr>
<tr>
<td>🔗</td>
<td>Align Left – Aligns selected text to the left with a jagged right margin</td>
</tr>
<tr>
<td>🔗</td>
<td>Align Center – Aligns text with the center of the document</td>
</tr>
<tr>
<td>🔗</td>
<td>Align Right – Aligns selected text to the right with a jagged left margin</td>
</tr>
<tr>
<td>🔗</td>
<td>Justify – Aligns text along the left and right margins</td>
</tr>
<tr>
<td>🔗</td>
<td>Numbering – Inserts numbers for a list, or deletes them from a selected numbered list</td>
</tr>
<tr>
<td>🔗</td>
<td>Bullets – Inserts bullets for a list, or deletes them from a selected bulleted list</td>
</tr>
<tr>
<td>🔗</td>
<td>Decrease Indent – Moves selected text one tab space to the left</td>
</tr>
<tr>
<td>🔗</td>
<td>Increase Indent – Moves selected text one tab space to the right</td>
</tr>
<tr>
<td>Font Color</td>
<td>Changes the color of selected text</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------</td>
</tr>
<tr>
<td>Select Objects</td>
<td>Changes the pointer to a selection arrow</td>
</tr>
<tr>
<td>Line</td>
<td>Draws a line in a document</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Draws a rectangle in a document. Hold the Shift key while drawing to make a perfect square.</td>
</tr>
<tr>
<td>Textbox</td>
<td>Inserts a textbox into a document</td>
</tr>
<tr>
<td>Insert Diagram</td>
<td>Inserts a diagram or chart into a Word document</td>
</tr>
<tr>
<td>Insert Picture from File</td>
<td>Inserts a picture from a location other than ClipArt</td>
</tr>
<tr>
<td>Line Color</td>
<td>Change the color of a selected line, arrow, border, or outline</td>
</tr>
<tr>
<td>Dash Style</td>
<td>Choose the dash pattern for a selected line, arrow, border, or outline</td>
</tr>
<tr>
<td>Shadow Style</td>
<td>Insert a shadow for selected item(s) and choose the shadow settings</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the help dialog box for the program you are using</td>
</tr>
<tr>
<td>Draw</td>
<td>Opens the draw menu</td>
</tr>
<tr>
<td>AutoShapes</td>
<td>Lets you choose a shape to draw</td>
</tr>
<tr>
<td>Arrow</td>
<td>Draws an arrow in a document</td>
</tr>
<tr>
<td>Oval</td>
<td>Draws an oval in a document, hold the Shift key while drawing to make a perfect circle.</td>
</tr>
<tr>
<td>WordArt</td>
<td>Creates effects to make text look fancier</td>
</tr>
<tr>
<td>Insert ClipArt</td>
<td>Opens the ClipArt window to let you search for and insert a picture</td>
</tr>
<tr>
<td>Fill Color</td>
<td>Color the interior of a selected shape with a color or pattern</td>
</tr>
<tr>
<td>Line Size</td>
<td>Change the thickness of a selected line, arrow, border, or outline</td>
</tr>
<tr>
<td>Arrow Style</td>
<td>Choose a design for a selected arrow</td>
</tr>
<tr>
<td>3-D Style</td>
<td>Insert 3-D effects for selected item(s) and choose the 3-D settings</td>
</tr>
</tbody>
</table>
AIM: Working with MS Excel

Microsoft Excel

Microsoft Excel is an electronic spreadsheet program. You might of heard the terms "spreadsheet" and "worksheet". People generally use them interchangeably. To remain consistent with Microsoft and other publishers the term worksheet refers to the row-and column matrix sheet on which you work upon and the term spreadsheet refers to this type of computer application. In addition, the term workbook will refer to the book of pages that is the standard Excel document. The workbook can contain worksheets, chart sheets, or macro modules.

Microsoft Excel is a spreadsheet application developed by Microsoft for Microsoft Windows and Mac OS. It features calculation, graphing tools, pivot tables, and a macro programming language called Visual Basic for Applications. It has been a very widely applied spreadsheet for these platforms, especially since version 5 in 1993, and it has replaced Lotus 1-2-3 as the industry standard for spreadsheets. Excel forms part of Microsoft Office.

To familiarize with parts of Excel window:

- **Active Cell**: The cell with the black outline. Data is always entered into the active cell.
**Column Letter**
Columns run vertically on a worksheet and each one is identified by a letter in the column header.

**Formula Bar**
Located above the worksheet, this area displays the contents of the active cell. It can also be used for entering or editing data and formulas.

**Name Box**
Located next to the formula bar, the Name Box displays the cell reference or the name of the active cell.

**Row Numbers**
Rows run horizontally in a worksheet and are identified by a number in the row header. Together a column letter and a row number create a cell reference. Each cell in the worksheet can be identified by this combination of letters and numbers such as A1, F456, or AA34.

**Sheet Tabs**
By default there are three worksheets in an Excel file. The tab at the bottom of a worksheet tells you the name of the worksheet - such as Sheet1, Sheet2 etc. Switching between worksheets can be done by clicking on the tab of the sheet you wish to access. Renaming a worksheet or changing the tab color can make it easier to keep track of data in large spreadsheet files.

**Quick Access Toolbar**
This customizable toolbar allows you to add frequently used commands. Click on the down arrow at the end of the toolbar to display the available options.

**Office Button**
Clicking on the Office Button displays a drop down menu containing a number of options, such as open, save, and print. The options in the Office Button menu are very similar to those found under the File menu in previous versions of Excel.

**Ribbon**
The Ribbon is the strip of buttons and icons located above the work area in Excel 2007. The Ribbon replaces the menus and toolbars found in earlier versions of Excel.

**Save a workbook with single and/or multiple worksheets**
First select the sheets (you can select multiple by holding the Control key), and the right-click on one of them.
Then choose "Move or Copy..."

Select (new book) and check "Create a copy";

After you've pressed the OK button you'll notice that a new workbook is created with the selected sheets only:

Now you have a new workbook with only the selected sheets which you can save as a new file.

**Change the format or font used for text**
Select the cell, range of cells, text, or characters that you want to format.
On the **Formatting** toolbar, do one of the following:
To change the text color, click the arrow next to **Font Color**，and then click a color on the palette.

To apply the most recently selected text color, click **Font Color**.

To change the background color, click the arrow next to **Fill Color**，and then click a color on the palette.

To apply the most recently selected background color, click **Fill Color**.

**Tip** If the Formatting toolbar is not displayed, point to Toolbars on the View menu, and then click Formatting.

**To apply operations on range of cells using built-in formulae**

Formulas are equations that perform calculations on values in your worksheet. A formula always starts with an equal sign (=).

You can create a simple formula by using constants and calculation operators. For example, the formula =5+2*3 multiplies two numbers and then adds a number to the result. Microsoft Office Excel follows the standard order of mathematical operations. In the preceding example, the multiplication operation (2*3) is performed first, and then 5 is added to its result.

You can also create a formula by using a function. For example, the formulas =SUM(A1:A2) and SUM(A1,A2) both use the SUM function to add the values in cells A1 and A2.

Depending on the type of formula that you create, a formula can contain any or all of the following parts.

1. **Functions** A function, such as PI(), starts with an equal sign (=). For many functions, such as SUM(), you can enter arguments within its parentheses. Each function has a specific argument syntax. Some arguments require exactly one argument, others require or allow several arguments (that is, some arguments might be optional), and some other functions allow no arguments at all — such as PI().

2. **Cell references** You can refer to data in worksheet cells by including cell references in the formula. For example, the cell reference A2 returns the value of that cell or uses that value in the calculation.

3. **Constants** You can also enter constants, such as numbers (such as or text values, directly into a formula.

4. **Operators** Operators are the symbols that are used to specify the type of calculation that you want the formula to perform. For example, the ^ (caret) operator raises a number to a power, and the * (asterisk) operator multiplies numbers.

**To preview and print a worksheet**

Do one of the following:

To print a partial worksheet, click the worksheet, and then select the range of data that you want to print.

To print the entire worksheet, click the worksheet to activate it.

To print a workbook, click any of its worksheets.

Click **Microsoft Office Button**，and then click **Print**.

**Keyboard shortcut** You can also press CTRL+P.

Under **Print what**, select an option to print the selection, the active sheet or sheets, or the entire workbook.
Note  If a worksheet has a defined print area, Excel will print only the print area. If you don't want to print a defined print area, select the **Ignore print areas** check box.

Tip  To print quickly or to preview the printout before you print, click **Microsoft Office Button** 📌, click the arrow next to **Print**, and then click **Quick Print** or **Print Preview**.

---

**To insert new row and/or column in a worksheet**

---

**Add Rows and Columns**

When you add a **row** to a spreadsheet, the rows of data below the insertion point are pushed down.

When you add a **column**, the columns of **data** to the right of the insertion point move to the right to make room.

*To add a row to a spreadsheet*

With the mouse pointer, right click on the row header below where you want the new row added. Choose **Insert** from the menu.

The new row will be inserted above the row you selected.

*To add multiple rows to a spreadsheet*

To add more than one new row, we select more than one row in the row header.

In the row header, **drag select** the number of rows you want added to the spreadsheet.

Right click on the selected rows. Choose **Insert** from the menu.

The new rows will be inserted above the rows you first selected.

*To add a column to a spreadsheet*

With the mouse pointer, right click on the column header where you want the new column added.

Choose **Insert** from the menu.

The new column will be inserted to the left of the selected column.

*To add multiple columns to a spreadsheet*

To add more than one new column, we select more than one column in the column header.

In the column header, **drag select** the number of columns you want added to the spreadsheet.

Right click on the selected columns. Choose **Insert** from the menu.

The new columns will be inserted to the left of the selected columns.

---

**Delete Rows and Columns**

---

**Before you delete**, it is important to realize that any data located in the rows or columns being deleted will be deleted as well. If you make a mistake use the **Undo** feature under the **Edit** menu to get your data back.

*To delete a row from a spreadsheet*

Right click on the row header of the row you want to delete

Choose **Delete** from the menu.

*To delete multiple rows from a spreadsheet*

In the row header, select the rows you want to delete.

Right click on the selected rows.

Choose **Delete** from the menu.

*To delete a column from a spreadsheet*

Right click on the column you want to delete.

Choose **Delete** from the menu.

*To delete multiple columns from a spreadsheet*

In the column header, select the columns you want to delete.

Right click on the selected columns.
Choose *Delete* from the menu.

**Create a Chart**

![Toy Sales Chart](image)

To create the column chart shown above, start by creating the worksheet below exactly as shown.

![Worksheet](image)

After you have created the worksheet, you are ready to create your chart. **Create a Column Chart**

![Insert Chart](image)

Select cells A3 to D6. You must select all the cells containing the data you want in your chart. You should also include the data labels.

Choose the Insert tab.
Click the Column button in the Charts group. A list of column chart sub-types types appears. Click the Clustered Column chart sub-type. Excel creates a Clustered Column chart and the Chart Tools context tabs appear.

**Apply a Chart Layout**

Context tabs are tabs that only appear when you need them. Called Chart Tools, there are three chart context tabs: Design, Layout, and Format. The tabs become available when you create a new chart or when you click on a chart. You can use these tabs to customize your chart.

You can determine what your chart displays by choosing a layout. For example, the layout you choose determines whether your chart displays a title, where the title displays, whether your chart has a legend, where the legend displays, whether the chart has axis labels and so on. Excel provides several layouts from which you can choose.

**Apply a Chart Layout**

Click your chart. The Chart Tools become available.
Choose the Design tab.
Click the Quick Layout button in the Chart Layout group. A list of chart layouts appears. Click Layout 5. Excel applies the layout to your chart.

**Add Labels**

When you apply a layout, Excel may create areas where you can insert labels. You use labels to give your chart a title or to label your axes. When you applied layout 5, Excel created label areas for a title and for the vertical axis.

**Add labels**

Select Chart Title. Click on Chart Title and then place your cursor before the C in Chart and hold down the Shift key while you use the right arrow key to highlight the words Chart Title.
Type **Toy Sales**. Excel adds your title.
Select Axis Title. Click on Axis Title. Place your cursor before the A in Axis. Hold down the Shift key while you use the right arrow key to highlight the words Axis Title.
Type **Sales**. Excel labels the axis.
Click anywhere on the chart to end your entry.

**Switch Data**

If you want to change what displays in your chart, you can switch from row data to column data and vice versa.

**Switch Data**

Click your chart. The Chart Tools become available.
Choose the Design tab.
Click the Switch Row/Column button in the Data group. Excel changes the data in your chart.

**Change the Style of a Chart**

A style is a set of formatting options. You can use a style to change the color and format of your chart. Excel 2007 has several predefined styles that you can use. They are numbered from left to right, starting with 1, which is located in the upper-left corner.

**Change the Style of a Chart**

Click your chart. The Chart Tools become available.
Choose the Design tab.
Click the More button in the Chart Styles group. The chart styles appear.
Click Style 42. Excel applies the style to your chart.

**Change the Size and Position of a Chart**

When you click a chart, handles appear on the right and left sides, the top and bottom, and the corners of the chart. You can drag the handles on the top and bottom of the chart to increase or decrease the height of the chart. You can drag the handles on the left and right sides to increase or decrease the width of the chart. You can drag the handles on the corners to increase or decrease the size of the chart proportionally. You can change the position of a chart by clicking on an unused area of the chart and dragging.

**Change the Size and Position of a Chart**

Use the handles to adjust the size of your chart.

Click an unused portion of the chart and drag to position the chart beside the data.

**Move a Chart to a Chart Sheet**

By default, when you create a chart, Excel embeds the chart in the active worksheet. However, you can move a chart to another worksheet or to a chart sheet. A chart sheet is a sheet dedicated to a particular chart. By default Excel names each chart sheet sequentially, starting with Chart1. You can change the name.

**Move a Chart to a Chart Sheet**
Click your chart. The Chart Tools become available.
Choose the Design tab.
Click the Move Chart button in the Location group. The Move Chart dialog box appears.

Click the New Sheet radio button.
Type Toy Sales to name the chart sheet. Excel creates a chart sheet named Toy Sales and places your chart on it.

**Change the Chart Type**
Any change you can make to a chart that is embedded in a worksheet, you can also make to a chart sheet. For example, you can change the chart type from a column chart to a bar chart.

**Change the Chart Type**

Click your chart. The Chart Tools become available.
Choose the Design tab.
Click Change Chart Type in the Type group. The Chart Type dialog box appears.
Click Bar.
Click Clustered Horizontal Cylinder.
Click OK. Excel changes your chart type.

Import a text file by opening it in Excel
You can open a text file that you created in another program as an Excel workbook by using the Open command. Opening a text file in Excel does not change the format of the file — you can see this in the Excel title bar, where the name of the file retains the text file name extension (for example, .txt or .csv).

Click the Microsoft Office Button, and then click Open. The Open dialog box appears.
On a computer that is running Windows Vista
In the list, select Text Files.
On a computer that is running Microsoft Windows XP
In the Files of type list, select Text Files.
On a computer that is running Windows Vista
In the Address bar, locate and double-click the text file that you want to open.
On a computer that is running Microsoft Windows XP
In the Look in list, locate and double-click the text file that you want to open.
If the file is a text file (.txt), Excel starts the Import Text Wizard. Follow the instructions in the Text Import Wizard. Click Help for more information about using the Text Import Wizard or see Text Import Wizard. When you are done with the steps in the wizard, click Finish to complete the import operation.
If the file is a .csv file, Excel automatically opens the text file and displays the data in a new workbook.
AIM: Working With Powerpoint
AIM: Write a program to find the nature of the roots as well as value of the roots. However, in case of imaginary roots, find the real part and imaginary part Separately.

```c++
#include<iostream.h>
#include<conio.h>
int main()
{
 clrscr();
 float a,b,c,d,root1,root2;
 cout<<"enter values of a,b,c: ";
 cin>>a>>b>>c;
 d=b*b-4*a*c;
 if(d==0)
 { 
 root1=(-b)/(2*a);
 root2=root1;
 cout<<"roots are real and equal ";
 else if(d>0)
 { 
 root1=(b+sqrt(d))/(2*a);
 root1=(b-sqrt(d))/(2*a);
 cout<<"roots are real and distinct ";
 }
 else
 { 
 root1=(-b)/(2*a);
 root2=sqrt(-d)/(2*a);
 cout<<"roots are imaginary ";
 cout<<"\nroot1"<<root1<<"\nroot2"<<root2;
 getch();
 return 0;
 }
```
AIM: write a program, which takes two integer operands and one operator from user, perform the result and prints the result.

```cpp
#include<iostream.h>
#include<conio.h>
int main()
{
    float op1,op2,res;
    char ch;
    cout<<"enter two numbers";
    cin>>op1>>op2;
    cout<<"n enter an operator";
    cin>>ch;
    cout<<"n";
    switch(ch)
    {
    case'+': res=op1+op2;
        break;
    case'-': res=op1-op2;
        break;
    case'*': res=op1*op2;
        break;
    case'/':if(op2==0)
        cout<<"divide by zero error";
        break;
    else
    res=op1/op2;
        break;
    default: cout<<"wrong operator";
    }
    cout<<"The result is:"<<res;
    return 0;
}
```
AIM: 

Fibonacci sequence is defined as follow the first and second terms in the sequence are 0 and 1. Subsequent terms are found by adding the preceding two terms in the sequence.

```c
#include<iostearm.h>
#include<conio.h>
int main()
{
    clrscr();
    unsigned long first,second,third,n;
    first=0;
    second=1;
    cout<<"how many elements in sequence:"; 
    cin>>n;
    cout<<"fibonacci series\n";
    cout<<first<<second;
    for(int i=0;i<n;++i)
    {
        third=first+second;
        cout<<"third is:"<<third;
        first=second;
        second=third;
    }
    return=0;
}
```
AIM: write a program to print the prime numbers between m and n.

```c
#include<iostream.h>
#include<conio.h>

void main()
{
    int m,n,i,j,check=0;
    cout<<"enter the values of m and n:";
    cin>>m>>n;
    for(int i=m;i<=n;i++)
    {
        num=i;
        check=;
        for(j=2;j<=num/i;i++)
        {
            if(num%j==)
            {
                check=1;
            }
        }
        if(check==)
        cout<<num<<" not prime\n";
    }
    getch();
}
```
AIM: write a program to check whether the given number is palindrome or not.

```c++
#include<iostream.h>
#include<conio.h>

void main()
{
    int n,num,digit,rev=0;
    cout<<"n input the number(max.32767):";
    cin>>num;
    do
    {
        digit=num%10;
        rev=(rev*10)+digit;
        num=num/10;
    }
    while(num!=0);
    cout<<"the reverse of number is:"<<rev<<"n";
    if(n==rev)
        cout<<"the no. is palindrome";
    else
        cout<<"n the number is not palindrome";
}
```
AIM: write a program that will find and display all possible three digit well-order numbers.

```cpp
#include<iostream.h>
#include<conio.h>

int main()
{
    int num,d1,d2,d3,temp,count=0;
    cout<<"well ordered numbers"<<endl;
    for(num=100;num<1000;num++)
    {
        temp=num;
        d3=temp%10;
        temp=temp/10;
        d2=temp%10;
        temp=temp/10;
        d1=temp%10;
        if(d1<d2&&d2<d3)
        {
            cout<<num<<"t";
            count++;
        }
    }
    cout<<"n total number of well-order numbers:"<<count<<endl;
    return 0;
}
```
AIM: write a program to compute the highest common factor of integer numbers m and n.

```c++
#include<iostream.h>
#include<conio.h>
int calcGCD(int a,int b);
int main()
{
    int a,b,gcd;
    cout<<"GCD or HCF of given numbers"<<a<<","<<b<<"is:"<<gcd<<endl;
    getchar();
    return 0;
}
int calGCD(int a,int b)
{
    int num,den,GCD,r;
    if(a>b)
    {
        num=a; den=b;
    }
    else
    {
        num=b;
        den=a;
    }
    while(den>1)
    {
        r=num%den;
        if(r==0)
        {
            GCD=den;
            break;
        }
        else
        {
            num=den;
            den=r;
        }
    }
    if(den==1)
    GCD=1;
    return GCD;
}
```
AIM: Write a program to obtain the following information: (a) minimum and maximum marks score (b) average score of the class and, (c) number of students whose score is greater than class's average score.

```
#include<iostream.h>
#include<conio.h>

const int size=30;

int main()
{
    double marks[size],sum=0,avgMarks=0,max=0,min=0,count=0;

    for(int i=0;i<size;i++)
    {
        cout<<"Enter marks for student"<<(i+1)<<":";
        cin>>marks[i];
        sum+=marks[i];
        if(marks[i]>max)
            max=marks[i];
        if(i==0) min=marks[0];
        else if(marks[i]<min)
            min=marks[i];
    }
    avgMarks=sum/size;

    for(int i=0;i<size;i++)
    {
        if(marks[i]>avgMarks)
            count++;
    }
```

Practical – 16
count++;
}

cout<<"maximun marks:"<<max<<endl;
cout<<"miniimun marks:"<<min<<endl;
cout<<"Average marks:"<<avgMarks<<endl;
cout<<"Number of student having score more than average score of the class:"<<count<<endl;
return 0;
}
AIM: Write a program to multiply matrix Am×n by Bp×q, given that n = p.

```c++
#include<iostream.h>
#include<conio.h>

int main()
{
    clrscr();
    int a[10][10], b[10][10], c[10][10];
    int x, y, i, j, m, n;
    cout << "Enter the number of rows and columns for Matrix A:::
    cin >> x >> y;
    cout << "Enter elements for Matrix A :::
    for(i=0;i<x;i++)
    {
        for(j=0;j<y;j++)
        {
            cin >> a[i][j];
        }
        cout << "
    }
    cout << "Matrix A :
    for(i=0;i<x;i++)
    {
        for(j=0;j<y;j++)
        {
            cout << "t" << a[i][j];
        }
        cout << "
    }
    cout << "
    Enter the number of rows and columns for Matrix B:::
    cin >> m >> n;
    cout << "Enter elements for Matrix B :::
    for(i=0;i<m;i++)
    {
        for(j=0;j<n;j++)
        {
            cin >> b[i][j];
        }
    }
    // Implement multiplication code here
    return 0;
}
```
cout<<"\n";
}
cout<<"\nMatrix B :\n\n";

for(i=0;i<m;i++)
{
    for(j=0;j<n;j++)
    {
        cout<<"t"<<b[i][j];
    }
    cout<<"\n\n";
}

if(y==m)
{
    for(i=0;i<x;i++)
    {
        for(j=0;j<n;j++)
        {
            c[i][j]=0;
            for(int k=0;k<m;k++)
            {
                c[i][j]=c[i][j]+a[i][k]*b[k][j];
            }
        }
    }
cout<<"\n-----------------------------------------------------------\n";
    cout<<"\n\nMultiplication of Matrix A and Matrix B :\n\n";
    for(i=0;i<x;i++)
    {
        for(j=0;j<n;j++)
        {
            cout<<"t"<<c[i][j];
        }
        cout<<"\n\n";
    }
}
else
{
    cout<<"\n\nMultiplication is not possible";
}

getch();
return 0;
AIM: Write a program to sort a list of n integer numbers in descending order using bubble sort method.

```c++
#include<iostream.h>
#include<conio.h>

Void main()
{
    Clrscr();
    int a[25],i,j,tmp,size;
    cout<<"n enter number of elements in the array:”;
    cin>>size;
    cout<<"n enter the elements of array:”;
    for (i=0;  i< size; i++)
        cin>>a[i];
    for (i=0;  i< size; i++)
    {
        int last = (size- 1) –i ;
        for(j=0; j<last; j++)
            if (a[j] < a[j+1])
            {
                tmp = a [j];
                a[j] = a[j+1]
                a[j+1] = tmp;
            }
    }
    cout<<"n array in descending order is:\n”;
    for(i=0; i< size; i++)
        cout<<a[i] <","n";
    getch();
}
```
AIM: Create a class with the appropriate data members and member functions.

```cpp
#include <iostream.h>
#include<conio.h>
class book
{
    Private:
        int bookno;
        char bname[30];
        char aurname[30];
        float bprice;
    public:
        void getdata()
        {
            cout<<"enter the details"
            cin>>bookno;
            cout<<"enter the book no";
            cin>>bname;
            cout<<"enter author name";
            cin>>aurname;
            cout<<"enter the book price";
            cin>>bprice;
        }

        void display()
        {
            cout<<"enter the record"
            cout<<"book no"<<bookno<<endl;
            cout<<"book name"<<bname<<endl;
            cout<<"author name"<<aurname<<endl;
            cout<<"book price"<<bprice<<endl;
        }
    
    void main()
    {
        class book obj;
        clrscr();
        obj.getdata();
        obj.display();
        getch();
    }
};
```
AIM: Create a class named Complex Number with the appropriate data members and constructors. Include member functions (defined inside the class) to perform the following operations:

(a) Inputting a complex number

(b) Outputting a complex number

(c) Arithmetic operations on two complex numbers

Write an appropriate program to demonstrate use of the Complex Number class.

```cpp
#include<iostream.h>
#include<string.h>

class complex
{
float real;
float imag;
public:
void input()
{
cout<<"enter p and q values for complex numbers";
cin>>real>>imag;
}
void output()
{
cout<<real<<"+"<<imag<<"i";
}
complex add(complex b);
complex subtract (complex b);
complex multiply (complex b);
complex divide (complex b);
};
complex complex::subtract (complex b)
{
complex c;
c.real = real-b.real;
c.imag=imag-b.imag;
return(c);
}
complex complex::multiply (complex b)
{
    complex c;
    c.real = ((real*b.real) – (imag * b.imag));
    c.imag=((real*b.real) + (imag * b.imag));
    return(c);
}
complex complex::add (complex b)
{
    complex c;
    c.real = real+b.real;
    c.imag=imag+b.imag;
    return(c);
}
complex complex::divide (complex b)
{
    complex c;
    c.real = ((b.real*b.real) + (imag * b.imag));
    c.imag=((real*b.real) + (imag * b.imag))/temp;
    return(c);
}
void main()
{
    complex a,b,c;
    int ch; char temp;
    void menu (void);
    cout<<"enter te first complex no:’”;
    a.input();
    cout<<"enter the second complex no’”;
    b.input();
;
    do
    {
        clrscr();
        menu();
        ch=getchar();
        fflush(stdin);
        switch(ch)
        {
        case ‘a’ : c = a.add(b);
            a.output();
            cout<<”plus”;
            b.output();
            cout<<”:”;
            c.output();
            temp = getchar();
            break;
        case ‘s’ : c = a.subtract(b);
            a.output();
            cout<<”minus”; 
            b.output();
        }
cout<<":\n;  
c.output();
temp = getchar();
break;
case 'm': c = a.multiply(b);
a.output();
cout<<"multiplied by\n;  
b.output();
cout<<":\n;  
c.output();
temp = getchar();
break;

case 'd': c = a.divide(b);
a.output();
cout<<"divided by\n;  
b.output();
cout<<":\n;  
c.output();
temp = getchar();
break;
}
cout<<endl;
}  
while (ch != 'q');
return 0;
}

void main()
{
cout<<"complex number: operators\n";
cout<<"addition \n";
cout<<"subtraction \n";
cout<<"multiplication \n";
cout<<"division \n";
cout<<"quit \n";
cout<<"choose desired option";
}
AIM: Create a class named Height with feet and inches as its data members. Also include appropriate constructors (and destructor, if required). Include member functions (defined outside the class) to perform the following operations:

(a) Inputting a height of a person
(b) Displaying a height of a person
(c) To get height in inches
(d) To compare two heights

Write an appropriate program to demonstrate use of the Height class.

```cpp
#include<iostream.h>
const int INCHES_PER_FOOT=12;
class height
{
private:
    int totalInches;
    int feet;
    int inches;
public:
    Height(void);
    Height(int f,int i);
    height(int totalInches);
    ~Height(void);
    void Height::convertTOFeetInches();
    void inputHeight()
    { int f,i;
        cout<<"enter height in feet and inches";
        cin>>feet>>inches;
        totalInches=feet*12+inches;
    }
    void display()
    {
        cout<<feet<<"\""<<inches<<"\""("<<totalInches<<"\""inches)"<<endL;
    }
};
```
int compare(Height t)
{
    if(totaLInches>t.totaLInches)
        return 1;
    else if(totaLInches==t.totaLInches)
        return 0;
    else
        return -1;
}

int getTotaLInches(void);
void setTotaLInches(int totaLInches);
}

height::height(void)
{
    totaLInches=0;
    feet=0;
    inches=0;
}

Height::Height(int f,int i)
{
    feet=f;inches=i;
    totaLInches=f*12+i;
}

Height::Height(int totaLInches)
{
    this->totaLInches=totaLInches;
    convertTOFeetInches();
}

Height::~height(void)
{
}

void Height::convertTOFeetInches()
{

feet = totalInches / INCHES_PER_FOOT;
inches = totalInches % INCHES_PER_FOOT;
}
int Height::getTotalInches(void)
{
    return totalInches;
}
void Height::setTotalInches(int totalInches;
convertToFeetAndInches();
}
int main()
{
    Height h1, h2;
    int totalInches, ft, inch;
    cout << "Enter height 1:\n";
    cout << "Please enter the total height in inches:";
    cin >> totalInches;
    h1.setTotalInches(totalInches);
    cout << "Enter height 2:\n";
    h2.inputHeight();
    h1.display();
    h2.display();
    int res = h1.compare(h2);
    if (res == 0)
        cout << "Both heights are equal" << endl;
    else if (res == 1)
        cout << "First height is greater" << endl;
    else
        cout << "Second height is greater" << endl;
    system("pause");
    return 0;
}
AIM: Write a program for display a message.

#include<iostream.h>
#include<conio.h>

void main()
{
    clrscr();
    cout<<"hello";
    getch();
}
AIM: Write a program for addition, subtraction, multiplication and Division of two integer numbers.

#include<iostream.h>
#include<conio.h>

void main()
{
clrscr();
int a,b,c,d,e,f;
cout<<"enter two numbers";
cin>>a>>b;
c=a+b;
cout<<"sum is:"<c;
d=a-b;
cout<<"subtraction is:"<<d;
e=a*b;
cout<<"multiplication is:"<<e;
f=a/b;
cout<<"division is:"<<f;
getch();
}
AIM: Write a program to find greatest of three numbers.

```c++
#include<iostream.h>
#include<conio.h>
void main()
{
    int num1,num2,num3;
    cout<<" Enter value for first number";
    cin>>num1;
    cout<<" Enter value for second number";
    cin>>num2;
    cout<<" Enter value for third number";
    cin>>num3;
    if(num1>num2&&num1>num3)
    {
        cout<<" First number is greatest:"<<endl<<"which is= "<<num1;
    }
    else if(num2>num1&&num2>num3)
    {
        cout<<" Second number is greatest"<<endl<<"which is= "<<num2;
    }
    else
    {
        cout<<" Third number is greatest"<<endl<<"which is= "<<num3;
    }
    getch();
}
```
AIM: Write a program to add two numbers using function.

```c
#include <iostream.h>
#include <conio.h>

void main()
{
    clrscr();
    int i,j,k;
    int add(int ,int);
    cout<<"\nENTER THE VALUE FOR THE FIRST VARIABLE:-->";
    cin>>i;
    cout<<"\nENTER THE VALUE FOR THE SECOND VARIABLE:-->";
    cin>>j;
    k=add(i,j);
    cout<<"\nTHE SUM IS :"<<k;
    getch();
}

int add(int i,int j)
{
    return i+j;
}
```